«前の日記(2009-08-12 (水)) 最新 次の日記(2009-08-14 (金))»  

まちゅダイアリー


2009-08-13 (木)

久しぶりに Mac を使ったら

久しぶりに Ruby で遊んでみようかと、軽い気持ちで Mac を起動したら大変なことに…。

ERROR:  While executing gem ... (Gem::InstallError)
    hoe requires RubyGems version >= 1.3.1
#!/bin/sh
port selfupdate
  • port で RubyGems の 1.3.4 をインストールしようと試みるが、以下のエラーが発生。
Command output: ERROR:  While executing gem ... (OptionParser::InvalidOption)
    invalid option: --vendor requires ruby 1.8.7+ (you have 1.8.6.111)
  • 1.8.6 から 1.8.7 に更新しなきゃダメか。うう、 Ruby のコンパイルからやり直しなのか… < イマココ

やっぱり、新しいモノを試すのなら vmware fusion 上に Ubuntu を入れた方が楽かもなぁ。

Tags: Mac Ruby
本日のツッコミ(全1件) [ツッコミを入れる]
しばた (2009-08-14 (金) 13:17)

これは理想的な yak shaving ですね!