«前の日記(2004-02-06 (金)) 最新 次の日記(2004-02-08 (日))»  

まちゅダイアリー


2004-02-07 (土)

tdiary.vim

先日みつけたtdiary.vimを試してみる。

cURLをインストールして、:TDiaryReplace しようとすると、こんなエラーがでた。

Forbidden.

そいうえば、更新用CGIを update.rb から update.cgi へ変えていたのを思い出す。 tdiary.vim のソースにて、update.rb と書かれていたのを update.cgi へと書き換えた。

で、vimにて日記を書いてアップロードすると、文字化けが発生。 ・・・なんで??

Tags: tDiary

emergeでのバージョン

先日、hotwaydのebuildは0.5.3が最新と書いたが、調べてみると 0.7.1のebuildが存在していることがわかった。

$ ls /usr/portage/net-mail/hotwayd
ChangeLog  files                 hotwayd-0.7.1.ebuild
Manifest   hotwayd-0.5.3.ebuild  metadata.xml

emergeでバージョンを指定するには、直接ebuildファイルを指定すればよいみたい。

$ emerge -up /usr/portage/net-mail/hotwayd/hotwayd-0.7.1.ebuild

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild     U ] sys-libs/ncurses-5.3-r5 [5.3-r2]
[ebuild     U ] sys-devel/m4-1.4-r1 [1.4]
[ebuild     U ] sys-devel/bison-1.875 [1.35]
[ebuild  N    ] sys-libs/db-4.1.25_p1-r3
[ebuild     U ] dev-libs/openssl-0.9.7c-r1 [0.9.6k]
[ebuild  N    ] dev-lang/python-2.3.3
[ebuild     U ] sys-apps/portage-2.0.50 [2.0.49-r21]
*** Portage will stop merging at this point and reload itself,
    recalculate dependencies, and complete the merge.

[ebuild     U ] sys-devel/libperl-5.8.2 [5.8.0]
[ebuild     U ] dev-lang/perl-5.8.2-r1 [5.8.0-r12]
[ebuild     U ] sys-devel/binutils-2.14.90.0.7-r4 [2.14.90.0.6-r6]
[ebuild     U ] sys-devel/gcc-3.3.2-r5 [3.2.3-r3]
[ebuild  N    ] sys-kernel/linux-headers-2.4.21
[ebuild     U ] sys-libs/glibc-2.3.2-r9 [2.3.2-r3]
[ebuild     U ] sys-devel/libtool-1.4.3-r3 [1.4.3-r1]
[ebuild     U ] dev-libs/libxml2-2.6.3 [2.5.8]
[ebuild     U ] net-mail/hotwayd-0.7.1 [0.5.3]

なぜ、(バージョンを指定せずに) emerge hotwayd とすると 0.7.1ではなく0.5.3が表示されるんだろう。 emerge -u system を実行していないからか、それとも他の理由があるのか。 どっちにしろ、まだよく仕組みが分かっていないなぁ。

Tags: Gentoo